Upgrading email newsletter server
Incident Report for Cacher
Resolved
We've finished the upgrade. All functionality should be restored.
Posted Oct 14, 2019 - 14:08 EDT
Update
Continuing upgrade.
Posted Oct 14, 2019 - 14:06 EDT
Investigating
We are currently upgrading our email newsletters service. Unsubscribe functionality may be temporarily broken.
Posted Oct 14, 2019 - 14:03 EDT
This incident affected: Email Newsletters.